Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libwmime3-1.2.0-1.1 RPM for armv6hl

From OpenSuSE Ports Tumbleweed for armv6hl

Name: libwmime3 Distribution: openSUSE Tumbleweed
Version: 1.2.0 Vendor: openSUSE
Release: 1.1 Build date: Thu Oct 29 14:43:05 2026
Group: System/Libraries Build host: reproducible
Size: 2166676 Source RPM: wmime-1.2.0-1.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://github.com/grommunio/wmime/
Summary: Library for working with MIME messages and IMAP/POP/SMTP
VMime is a C++ class library for working with RFC5322 and
MIME-conforming messages (RFC2045–2049), as well as Internet
messaging services like IMAP, POP or SMTP.

VMime can parse, generate and modify messages, and also connect to
store and transport services to receive or send messages over the
Internet. The library offers features to build a mail client.

Provides

Requires

License

GPL-3.0-or-later

Changelog

* Tue Oct 27 2026 Jan Engelhardt <jengelh@inai.de>
  - Update to release 1.2.0
    * Removed extraneous `const` qualifiers on return types that
      prevented feeding generate() return values to another function
      as movable rvalues.
    * Over-encoding ASCII words in RFC 6532 mode is avoided.
    * The Date: line parser is now in line with RFC 5322, abolishing
      recognition for single-letter time zones previously availablein
      RFC 822.
    * Added support for IMAP ID extension.
    * Added support for Cygwin.
    * Header folding is now in accordance with RFC 5322/2047.
    * In e.g. To: address lists, '(' and '<' were erroneously parsed
      as comment and start of address even when they appeared in a
      quoted display name, which has been fixed.
  - Add i387.patch
* Thu Jul 24 2025 Jan Engelhardt <jengelh@inai.de>
  - Update to release 1.1.0
    * Preserve original MIME boundary when parsing and regenerating
      messages
    * POSIX platforms: avoid having undefined bytes in
      generateRandomBytes result
    * Avoid ODR violation resulting from different struct layouts
      per translation unit
* Tue Jan 21 2025 Jan Engelhardt <jengelh@inai.de>
  - Switch upstream location from vmime to wmime
  - Update to release 1.0.0
    * No further changes from last snapshot (0.9.2+git203)
  - Drop libvmime-soname.diff (merged in 1.0.0)
  - Rename libvmime-nodatetime.diff to nodate.patch
* Wed Jul 24 2024 Jan Engelhardt <jengelh@inai.de>
  - Update libvmime-soname.diff to support out-of-tree cmake builds
* Wed Jun 19 2024 Jan Engelhardt <jengelh@inai.de>
  - Update to snapshot 0.9.2+git203 (43b262bd)
    * another potential multiplication overflows
    * build: upgrade to C++17 when ICU is used
    * Fix a test failure in testNewFromString and
      pathTest::testGenerate
* Tue May 21 2024 Jan Engelhardt <jengelh@inai.de>
  - Update to snapshot 0.9.2+git196 (d296c2d)
    * vmime: prevent loss of a space when a multi-word mailbox name
      contains an umlaut
* Wed Apr 24 2024 Jan Engelhardt <jengelh@inai.de>
  - Update to snapshot 0.9.2+git191 (d03ad5f0)
    * url: fix an off-by-one error in parsing hostnames
    * url: strip leading slash from url-path
    * Support FIPS under OpenSSL 3
* Sun Feb 25 2024 Jan Engelhardt <jengelh@inai.de>
  - Reinstate %optflags
* Sun Dec 31 2023 Jan Engelhardt <jengelh@inai.de>
  - Update to snapshot 0.9.2+git188 (c3c6242ed)
    * Fix emission of bugs Envelope-From to sendmail:// transports.
    * Add parsing feedback via parsingContext
  - Drop 0001-Avoid-generating-illegal-Envelope-From-with-sendmail.patch
    (merged)
* Mon Dec 18 2023 Jan Engelhardt <jengelh@inai.de>
  - Add 0001-Avoid-generating-illegal-Envelope-From-with-sendmail.patch

Files

/usr/lib/libwmime.so.3
/usr/lib/libwmime.so.3.0.0
/usr/share/licenses/libwmime3
/usr/share/licenses/libwmime3/COPYING


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Nov 11 04:33:02 2026