| Index | index by Group | index by Distribution | index by Vendor | index by creation date | index by Name | Mirrors | Help | Search |
| Name: leapp-upgrade-el9toel10-deps | Distribution: CentOS |
| Version: 0.25.0 | Vendor: CentOS |
| Release: 2.el9 | Build date: Wed Sep 16 13:10:02 2026 |
| Group: Unspecified | Build host: aarch64-03.stream.rdu2.redhat.com |
| Size: 0 | Source RPM: leapp-repository-0.25.0-2.el9.src.rpm |
| Packager: builder@centos.org | |
| Url: https://oamg.github.io/leapp/ | |
| Summary: Meta-package with system dependencies of leapp-upgrade-el9toel10 package | |
Meta-package with system dependencies of leapp-upgrade-el9toel10 package
ASL 2.0
* Tue Sep 15 2026 Petr Stodulka <pstodulk@redhat.com> - 0.25.0-2 - Fix CVE-2026-75092 to secure the scan of mysql configuration - Resolves: RHEL-243195 * Thu Jul 30 2026 Matej Matuska <mmatuska@redhat.com> - 0.25.0-1 - Rebase on upstream version 0.25.0 - Inhibit the upgrade when machine ID is missing or invalid - Fix check of Ceph/LUKS volumes based on UUIDs - Do not crash when failing to mount a pseudo filesystem during upgrade - Prevent hanging system upgrade boot on systems with RAID and defined ‘resume’ on kernel command line - Introduce upgrades with conversions from Rocky Linux - Resolves: RHEL-188370, RHEL-151413, RHEL-155964, RHEL-155965, RHEL-155972, RHEL-180965, RHEL-187004, RHEL-193717, RHEL-133938 * Thu Jun 25 2026 Karolina Kula <kkula@redhat.com> - 0.24.0-3 - Requires leapp-framework 6.6+ - Initial implementation of upgrades on systems with configured Software RAID - Install the kernel variant matching the system memory page size on ARM systems - Check and migrate the multipath configuration when possible - Fix multipath device initialization race in the upgrade environment - Detect misconfigured /var/run on the source system - Detect misconfigured kernel & systemd API mountpoints in FSTAB - Drop the inconsistent report about used CRB repositories - Ensure SELinux is set to permissive mode during the upgrade even when enforcing=1 is set on the kernel cmdline - Fix additional AVC SELinux warnings - Fix mount failures for FSTAB entries with the `nofail` option specified - Fix source and target distribution names in /etc/migration-results - Fix target system initramfs containing outdated configuration files in some circumstances - Fix the pulseaudio scan for users with no home directory - Fix unwanted suspend mode after 15 minutes of inactivity after the upgrade on systems with graphical environment - Fix upgrade crashing when dnf repofiles contain URL encoded characters - Fix upgrade incorrectly resuming during SELinux relabeling - Fix upgrades for systems with /boot/efi on a Software RAID - Fix upgrades on systems with multiple LUKS devices - Fix upgrades with the RealTime kernel on CentOS Stream - Introduce rhui.obsolete_gpg_keys configuration option for the removal of obsoleted RPM GPG keys of RHUI Cloud providers - LiveMode: Fix system version determination in the upgrade environment on CentOS Stream - LiveMode: Fix upgrade getting stuck when the `.leapp_upgrade_failed` file exists - Unify behaviour of upgrades on systems with enabled CRB repositories and explicitly required CRB repositories by user during the upgrade - Resolves: RHEL-111860, RHEL-115867, RHEL-121205, RHEL-147438, RHEL-148697, RHEL-151509, RHEL-154369, RHEL-154370, RHEL-156580, RHEL-161560, RHEL-161684, RHEL-174874 * Fri Apr 17 2026 Petr Stodulka <pstodulk@redhat.com> - 0.24.0-2 - Introduce new upgrade path 9.9 -> 10.3 - Requires leapp-framework 6.5+ - Configure the net.naming-scheme when upgrading CS 9 to 10 - Fix scan of physical network interfaces and ethX detection - Fix quoting in list representation of remediation commands - Check PulseAudio configuration incompatible with PipeWire - Consider RHUI source clients as signed by distribution vendor - Ensure that greenboot packages are removed during the upgrade - Fix AVC SELinux warnings caused by leapp execution - Fix detection of network interfaces with biosdevname naming on Dell machines - Fix failing upgrades with hugetlbfs file systems specified in FSTAB - Fix the upgrade with LiveMode on systems with FIPS - Introduce DISTRO_REPORT_NAMES in the distro library to provide unified names for linux distributions for the use in leapp reports - Livemode: Fix the upgrade on systems where the generated live image is not in rootfs - Modify keys for several reports that have been inconsistent between major releases. The keys are now independent of the used upgrade path - Respect names of distributions used for the IPU in preupgrade reports - Minor updates in reports - Update leapp data files - Resolves: RHEL-1771, RHEL-72140, RHEL-148291, RHEL-150278, RHEL-156902 * Tue Feb 10 2026 Karolina Kula <kkula@redhat.com> - 0.24.0-1 - Rebase to new upstream 0.24.0 - Introduce new IPU path 9.8 -> 10.2 - Remove obsoleted IPU paths - Handle the upgrade on systems with NVMe-FC storage - Added scan and checks for NVMe devices, inhibitingblocking upgrades on known problematic setups - Check installed Xorg RPMs for removed content - Detect installed Motif packages when upgrading to RHEL - Drop inhibitor for use of LiveMode on aarch64, s390x, ppcle64 architectures - Fix the leapp rerun command when upgrading using LiveMode - Ignore trailing slashes when checking that required mountpoints are persistent - Improve the error message when a problematic DNF repository definition is detected - Inhibit the upgrade when converting system to a different linux distribution with enabled Secure Boot - LiveMode: Do not install RPMs that are not essential in the initramfs by default - Migrate the UEFI configuration when converting to RHEL - Process enabled DNF module-streams correctly during the upgrade - Setup net.naming-scheme to handle NIC names correctly when upgrading to RHEL 10.2+ (not applied for Centos 10 yet) - Update CA bundle path in kerberos configuration - Wait until filesystems defined in FSTAB are initialized and mounted when booting into the upgrade environment - Resolves: RHEL-65265, RHEL-74265, RHEL-108106, RHEL-128266, RHEL-133549, RHEL-135847, RHEL-141861 * Wed Dec 17 2025 Karolina Kula <kkula@redhat.com> - 0.23.0-3 - Fix handling of LVM during the upgrade - Deliver initial improvements for Multipath during the upgrade - Fix remediation command to make symlimk in root directory relative - Remove RPM GPG keys of the source distribution when converting system - Replace distro specific packages during conversion - Improve error message when scanning invalid SSHD configuration - Update the leapp data files - Minor changes in logs and reports - Resolves: RHEL-110190, RHEL-110568 * Thu Nov 13 2025 Petr Stodulka <pstodulk@redhat.com> - 0.23.0-2 - Requires leapp-framework 6.2+ - Modernize the storage initialization when booting to the upgrade environment - Fix the upgrade on s390x LPAR when rootfs is on LVM - Fix the detection of encrypted Ceph OSD containers - Fix unlocking of LUKS devices when applied on non-rootfs file systems - Detect potentially harmful third party python modules for the target python version - Handle correctly live kernel patching during IPU - Inhibit the upgrade if pluginpath is configured explicitly in DNF - Introduce `--target-os` option to specify target distribution for possible conversion during the upgrade - Introduce the `--target-version` alias for the `--target` option - Minor changes in logs and reports - Prevent sssdupdate actor from rising errors that could stop the upgrade - Respect repomapping on CentOS-like distributions - Respect repomapping when converting the system to different Linux distribution - Skip empty lines when parsing dumped DNF config to prevent confusing warning log - Update the leapp data files - Resolves: RHEL-76159, RHEL-95983, RHEL-108025, RHEL-108992, RHEL-110563, RHEL-119546 * Thu Aug 14 2025 Karolina Kula <kkula@redhat.com> - 0.23.0-1 - Rebase to new upstream 0.23.0 - Enable in-place upgrades on CentOS Stream systems - Inhibit the upgrade on systems using deprecated network-legacy dracut module to prevent kernel panic - Introduce leapp-upgrade-el9toel10-fapolicyd subpackage with fapolicyd rules for in-place upgrades - Ignore Red Hat subscription-manager actions on non-RHEL distros - Add actors to migrate SSSD configuration - Update leapp upgrade data files - Resolves: RHEL-50847, RHEL-80333, RHEL-86226, RHEL-95975, RHEL-95982, RHEL-102591, RHEL-104389 * Thu Jul 17 2025 Karolina Kula <kkula@redhat.com> - 0.22.0-4 - Load DNF configuration correctly when using DNF libraries - Disable localpkg_gpgcheck during the upgrade if set to allow installation of bundled leapp and leapp-repository deps packages - Enable upgrades on systems using RHUI on AWS and Azure - Inhibit the upgrade if cgroups v1 are enabled on the system - The HybridImage model has been replaced by ConvertGrubenvTask - Check the input format of the target version properly - Resolves: RHEL-64910, RHEL-64911, RHEL-81212 * Thu Jun 05 2025 Karolina Kula <kkula@redhat.com> - 0.22.0-3 - Fix parsing of the kernel cmdline - Require leapp data with provided_data_streams 4.0+ - Respect the release_id of the OS when processing DNF repositories to apply correct mapping for CentOS Stream - Resolves: RHEL-80336 * Wed May 14 2025 Petr Stodulka <pstodulk@redhat.com> - 0.22.0-2 - Require leapp-framework >= 6.1 - Simplified use of the LiveMode experimental feature with additional enhancements - Ensure the leapp-upgrade-el9toel10 RPM is not touched during the upgrade transaction - Create proper error message when swap of RHUI clients fails - Fix the check of deprecated PCI devices and drivers - Add RHEL 10.1 product certificates - Gracefully handle CentOS OS versioning style - Introduced the --enable-experimental-feature to simplify use of experimental features - Manage RPM GPG keys during the upgrade respecting used linux distributions - Prevent a crach during post-upgrade phases when no custom SELinux modules needs to be migrated - Update leapp upgrade data files - Minor fixes in reports - Resolves: RHEL-49402, RHEL-72544, RHEL-77175, RHEL-80334, RHEL-80335, RHEL-80336, RHEL-80550, RHEL-86689 * Fri Feb 14 2025 Petr Stodulka <pstodulk@redhat.com> - 0.22.0-1 - Rebase to new upstream 0.22.0 - Minor updates in generated reports - Cover upgrades for MySQL and PostgreSQL databases - Detect OpenSSL engines configured in /etc/pki/tls/openssl.cnf - Detect deprecated network-scripts (ifcfg) files - Detect whether subscribed systems are using SCA - Inform user about Libdb removal if present - Check and handle upgrades with custom crypto policies - Update checks for SAP HANA - Resolves: RHEL-57043, RHEL-35618, RHEL-36661, RHEL-62689, RHEL-68309, RHEL-69831, RHEL-77169, RHEL-78396 * Wed Jan 29 2025 Petr Stodulka <pstodulk@redhat.com> - 0.21.0-6 - Detect XFS file systems with problematic parameters - Raise an inhibitor if unsupported target version supplied instead of error - Prevent a possible crash with LiveMode when adding the upgrade boot entry on systems with LVM - Resolves: RHEL-57043, RHEL-52309, RHEL-60034 * Fri Jan 17 2025 Petr Stodulka <pstodulk@redhat.com> - 0.21.0-5 - Obsolete RHEL9 GPG key signed with SHA1 - Activate LVM VGs with `--sysinit` option to correct the use in the upgrade initramfs - Fix output of commands executed inside systemd-nspawn containers - Fix pes events scanner crashing when there are duplicate packages in the received instructions - Fix pes events scanner not respecting user’s transaction configuration - Fix remediation instructions for deprecated NM configuration - Fix storage scanner crashing when command outputs contain colon character - Minor improvements in preupgrade reports - Resolves: RHEL-57043, RHEL-31428, RHEL-33373, RHEL-69829, RHEL-71517 * Mon Nov 18 2024 Matej Matuska <mmatuska@redhat.com> - 0.21.0-4 - Require leapp-framework 6.0+ - Update leapp-deps package to satisfy leapp-framework-dependencies 6 - Add dependency on libdb-utils - Enable upgrade for systems with LUKS bound to Clevis with TPM 2.0 token - Adjust resource limitations for leapp to be able to perform the upgrade - Cap max size of the sparse files to 1TiB for storage with large amount of free space - Check that detected Intel CPU microarchitecture is supported on target system - Fix the report when handling broken parsing of kernel cmdline - Generate proper error message instead of ModelViolationError when parsing invalid repository definition - Handle default kernel cmdline when multiple boot entries for the default kernel are defined - Migrate Ruby IRB during the upgrade - Migrate pam_userdb backend during the upgrade - Skip checking of (PKI) `directory-hash` dir to speedup the upgrade process and clean logs - Update leapp upgrade data files - Resolves: RHEL-57043 * Thu Sep 19 2024 Petr Stodulka <pstodulk@redhat.com> - 0.21.0-3 - Rebuild to apply changes for gating - Resolves: RHEL-57043
Generated by rpm2html 1.8.1
Fabrice Bellet, Thu Oct 1 04:00:21 2026