| Index | index by Group | index by Distribution | index by Vendor | index by creation date | index by Name | Mirrors | Help | Search |
| Name: 389-ds-base | Distribution: AlmaLinux |
| Version: 3.3.0 | Vendor: AlmaLinux |
| Release: 4.el10 | Build date: Mon Sep 14 19:20:27 2026 |
| Group: Unspecified | Build host: x64-builder01.almalinux.org |
| Size: 12202261 | Source RPM: 389-ds-base-3.3.0-4.el10.src.rpm |
| Packager: AlmaLinux Packaging Team <packager@almalinux.org> | |
| Url: https://www.port389.org/ | |
| Summary: 389 Directory Server (base) | |
389 Directory Server is an LDAPv3 compliant server. The base package includes the LDAP server and command line utilities for server administration.
GPL-3.0-or-later WITH GPL-3.0-389-ds-base-exception AND (Apache-2.0 OR Apache-2.0 WITH LLVM-exception OR MIT) AND (Apache-2.0 OR LGPL-2.1-or-later OR MIT) AND (Apache-2.0 OR MIT) AND (MIT OR Apache-2.0) AND Unicode-3.0 AND (MIT OR Unlicense) AND Apache-2.0 AND MIT AND MPL-2.0 AND Zlib
* Fri Sep 11 2026 Viktor Ashirov <vashirov@redhat.com> - 3.3.0-4
- Bump version to 3.3.0-4
- Resolves: RHEL-183077 - CVE-2026-11770 389-ds-base: 389-ds-base: pre-auth
LDAP filter injection in CleanAllRUV status check [rhel-10.3]
- Resolves: RHEL-186031 - Compression of large logs can make the server
unresponsive
- Resolves: RHEL-191329 - lib389 is missing helper functions for reading
ASAN files
- Resolves: RHEL-210882 - CVE-2026-15722 389-ds-base: 389-ds-base: pre-
authentication stack buffer overflow in get_ruvelement_from_berval() via
unbounded replica ID parsing [rhel-10.3]
- Resolves: RHEL-215693 - Replication performance degradation during total
init on high-latency storage
- Resolves: RHEL-216719 - ERR - idl_new_range_fetch - Failed to build range
candidate list on entryusn index [rhel-10]
- Resolves: RHEL-220499 - CVE-2026-18355 389-ds-base: 389-ds-base: heap
buffer overflow via SASL wrapped-record length lower-bound underflow in
sasl_io_start_packet() [rhel-10.3]
- Resolves: RHEL-222323 - CVE-2026-18453 389-ds-base: 389-ds-base: pre-
authentication NULL pointer dereference via paged results and
USE_ONE_BACKEND control in op_shared_search [rhel-10.3]
- Resolves: RHEL-232865 - CVE-2026-18922 389-ds-base: 389-ds-base: SASL
PLAIN authentication allows privilege escalation to Directory Manager via
stale identity in Cyrus SASL auxiliary property [rhel-10.3]
- Resolves: RHEL-245382 - CVE-2026-76560 389-ds-base: 389-ds: anonymous
LDAP client can defeat SELFDN ACI bind-rule checks via empty bind DN
[rhel-10.3]
- Resolves: RHEL-248693 - CVE-2026-11770 fix breaks replication total init
when nsDS5ReplicaBindDNGroup is set after agreement creation
* Wed Aug 19 2026 Simon Pichugin <spichugi@redhat.com> - 3.3.0-3
- Bump version to 3.3.0-3
- Issue 6387 - Use make macro in the spec file
- Resolves: RHEL-80254 - [RFE] Provide a way to check for leaked passwords
- Resolves: RHEL-80257 - [RFE] Should be able to monitor the importing
progress via the CLI
- Resolves: RHEL-149760 - IPA - segfault with libjemalloc.so.2
- Resolves: RHEL-153098 - [RFE] Enable USDT probes in production builds
- Resolves: RHEL-171355 - 389-ds accountpolicy.py attribute name typo in
help message
- Resolves: RHEL-213991 - repl-agmt create doesn't set some parameters
- Resolves: RHEL-243048 - large IdM host group, missing memberof host
group, authentication failures, high traffic and contention [rhel-10]
- Resolves: RHEL-129204 - Local password policies can be created with
unallowed values
- Resolves: RHEL-238569 - lib389: join_supplier() sets
nsDS5ReplicaBindDNGroup after ensure_agreement(), causing replication
auth race [rhel-10]
- Resolves: RHEL-182157 - CVE-2026-11610 389-ds-base: 389-ds-base: Heap
buffer overflow in sasl_io_recv() via padded SASL UNBIND [rhel-10.3]
* Thu Jul 30 2026 Simon Pichugin <spichugi@redhat.com> - 3.3.0-2
- Bump version to 3.3.0-2
- Resolves: RHEL-146147 - Fix dsconf to allow specifying multiple
certificates for use in 389-ds server
- Resolves: RHEL-182463 - Error: NssSsl.add_cert() got an unexpected
keyword argument 'input_file'
- Resolves: RHEL-166737 - import_monitor_threads and average rate
214748364.8/sec rate calculation issue
- Resolves: RHEL-153372 - dirsrv@.service missing NoNewPrivileges and
MemoryDenyWriteExecute despite broad capability set
- Resolves: RHEL-164610 - Online reinitialization is failing with the
supplier being busy calling idrange_add_id()
- Resolves: RHEL-153094 - [RFE] Thread pool state mmap file with dsctl and
cn=monitor exposure
- Resolves: RHEL-129204 - Local password policies can be created with
unallowed values
- Resolves: RHEL-185139 - Compressed logs are prematurely deleted
- Resolves: RHEL-183383 - Post-import cache autotuning does not recompute
entry cache size
- Resolves: RHEL-190780 - CVE-2026-11788 389-ds-base: 389-ds-base: NULL
pointer dereference in defer control plugin BER parser [rhel-10.3]
- Resolves: RHEL-183109 - CVE-2026-11774 389-ds-base: 389-ds-base: integer
overflow in SASL packet length bypasses size limit leading to heap buffer
overflow [rhel-10.3]
* Fri Jun 05 2026 Viktor Ashirov <vashirov@redhat.com> - 3.3.0-1
- Bump version to 3.3.0
- Resolves: RHEL-58681 - high wtime can hide a worker reading a large
requests
- Resolves: RHEL-62876 - Inconsistencies in the log messages
- Resolves: RHEL-68692 - Replication halt caused by an incorrect setting of
"nsslapd-changelogmaxage"
- Resolves: RHEL-76836 - Crash in replica_config_add when manually
configuring a replica with an incorrect nsds5ReplicaRoot.
- Resolves: RHEL-80256 - [RFE] RHDS healthcheck tool could provide more
information in offline mode
- Resolves: RHEL-84531 - access log - suspicious wtime optime negative and
large values in internal op
- Resolves: RHEL-86325 - dbscan utility not filtering using -k option
- Resolves: RHEL-88942 - LDAP healthcheck and ignoring entrydn index and
associated config
- Resolves: RHEL-109505 - Possible memory leak when using the Retro
Changelog plugin.
- Resolves: RHEL-117666 - [RFE] Expose stats from deferred memberof
- Resolves: RHEL-118811 - Password policy can be created even though the
same one already exists
- Resolves: RHEL-118867 - Memory leak issue in an IPA deployment.
- Resolves: RHEL-121119 - Differences on export ldif using online of off-
line method on RHDS
- Resolves: RHEL-121169 - dsctl should report error when the ldif to import
doesn't have permissions to be read by dirsrv.
- Resolves: RHEL-129204 - Local password policies can be created with
unallowed values
- Resolves: RHEL-129597 - Remediate "Could not read password attribute"
error on directory Servers with chaining enabled(DBLink)
- Resolves: RHEL-132767 - An online reinitialization with LMDB is
terminating the receiving server
- Resolves: RHEL-134188 - RFE: add server-side configuration to ignore
malformed controls and/or override critical controls from clients
- Resolves: RHEL-138569 - AddressSanitizer: SEGV
ldap/servers/plugins/automember/automember.c:1962 in
automember_mod_post_op
- Resolves: RHEL-140005 - Memory leaks in IPA context on server restart
- Resolves: RHEL-141049 - Fail open condition in ACL
- Resolves: RHEL-141480 - [RFE] Add shadowLastChange fixup task
- Resolves: RHEL-146147 - Fix dsconf to allow specifying multiple
certificates for use in 389-ds server
- Resolves: RHEL-149125 - dnaSharedConfig: "dnaPortNum: 0"
- Resolves: RHEL-151246 - dsctl healthcheck DSMOLE0001 inaccurate
recommendations when there is more than 1 LDAP backend
- Resolves: RHEL-152373 - Entry cache DN hash table corruption causes
SIGSEGV in ns-slapd
- Resolves: RHEL-153088 - [RFE] Add OS-level thread names to all server
threads
- Resolves: RHEL-153089 - [RFE] Add work queue metrics to cn=monitor
- Resolves: RHEL-153092 - [RFE] Per-operation thread pool context via STAT
extension
- Resolves: RHEL-153372 - dirsrv@.service missing NoNewPrivileges and
MemoryDenyWriteExecute despite broad capability set
- Resolves: RHEL-154374 - Prevent the ability of creating a replication
agreement from a node back to itself is needed
- Resolves: RHEL-154380 - DS 12 does not handle escape char in bind user
- Resolves: RHEL-157894 - Online export is failing when using the option
"-s"
- Resolves: RHEL-163373 - WARN - keys2idl - received NULL idl from
index_read_ext_allids
- Resolves: RHEL-165956 - can't modify user's name/dn if it's owner of
SubIDs
- Resolves: RHEL-169529 - Rebase 389-ds-base to 3.3.x
- Resolves: RHEL-170277 - Memory leaks in syncrepl plugin during persistent
search operations
- Resolves: RHEL-170643 - passwordbadwords attribute of the local password
policy is not functioning
- Resolves: RHEL-170907 - Substring index produces empty results and can
crash when non-default nsSubStrBegin/nsSubStrEnd lengths are configured
- Resolves: RHEL-172228 - Replacing a group's member list modifies users
who were already members
- Resolves: RHEL-174908 - Replication errors in logs
- Resolves: RHEL-181022 - Server shutdown during online reindex may lead to
data loss
* Thu Mar 05 2026 Viktor Ashirov <vashirov@redhat.com> - 3.2.0-6
- Bump version to 3.2.0-6
- Resolves: RHEL-86312 - Crash in trim_changelog() during the Retro
Changelog trimming.
* Sat Feb 28 2026 Viktor Ashirov <vashirov@redhat.com> - 3.2.0-5
- Bump version to 3.2.0-5
* Fri Feb 27 2026 Viktor Ashirov <vashirov@redhat.com> - 3.2.0-4
- Bump version to 3.2.0-4
- Resolves: RHEL-86312 - Crash in trim_changelog() during the Retro
Changelog trimming.
- Resolves: RHEL-133085 - Replica installation is failing with message
MDB_BAD_VALSIZE: Unsupported size of key/DB name/data, or wrong DUPFIXED
- Resolves: RHEL-137072 - CVE-2025-14905 389-ds-base: 389-ds-base: Remote
Code Execution and Denial of Service via heap buffer overflow [rhel-10.2]
- Resolves: RHEL-138729 - Crash ( Segmentation fault ) in
atomic_compare_exchange()
* Fri Feb 20 2026 Viktor Ashirov <vashirov@redhat.com> - 3.2.0-3
- Bump version to 3.2.0-3
- Resolves: RHEL-76835 - Web console doesn't show the sub suffix of
ou=foo,ou=people,dc=example,dc=com.
- Resolves: RHEL-86320 - [RFE] Support updating/renewing TLS certificate
without restarting slapd
- Resolves: RHEL-110192 - ns-slapd doesn't support PQC keys
- Resolves: RHEL-111220 - RHDS-11.9 dsctl db2index --attr recreates all
indexes instead of selected ones
- Resolves: RHEL-111931 - Improve error messages for dsconf localpwp list
- Resolves: RHEL-121981 - Setting password history count to 0 does not
flush history
- Resolves: RHEL-122625 - ipa-healthcheck is complaining about missing or
incorrectly configured system indexes.
- Resolves: RHEL-128906 - Scalability issue of replication online
initialization with large database
- Resolves: RHEL-137786 - Upgrading IDM to latest version: 389-ds-base and
ipa-server breaks replication
- Resolves: RHEL-146769 - Remove memberof_del_dn_from_groups from MemberOf
plugin
* Mon Jan 12 2026 Viktor Ashirov <vashirov@redhat.com> - 3.2.0-2
- Resolves: RHEL-137786 - Upgrading IDM to latest version: 389-ds-base and
ipa-server breaks replication
* Thu Jan 08 2026 Viktor Ashirov <vashirov@redhat.com> - 3.2.0-1
- Update to 3.2.0
- Resolves: RHEL-18041 - [RFE] When there are multiple backends cache auto-
tune should adapt its tuning
- Resolves: RHEL-58682 - [RFE] modify entry cache eviction strategy to
allow large groups to stay in the cache
- Resolves: RHEL-64019 - Units for changing MDB max size are not consistent
across different tools
- Resolves: RHEL-83274 - Replication online reinitialization of a large
database gets stalled.
- Resolves: RHEL-83852 - LDAP high CPU usage while handling indexes with
IDL scan limit at INT_MAX
- Resolves: RHEL-86534 - [RFE] Support Dynamic Groups similar to OpenLDAP
- Resolves: RHEL-89601 - (&(cn:dn:=groups)) no longer returns results
- Resolves: RHEL-94025 - PAM Pass Through Authentication Plugin processes
requests for accounts that do not meet the criteria specified in the
`pamFilter` option.
- Resolves: RHEL-95395 - Getting "build_candidate_list - Database error 11"
messages after migrating to LMDB.
- Resolves: RHEL-96196 - Duplicate/double local password policy entry
display from redhat directory server webconsole
- Resolves: RHEL-99331 - [RFE] Need an option with dsconf to delete all the
conflicts at once instead of deleting each conflict one after the other
- Resolves: RHEL-105578 - IPA health check up script shows time skew is
over 24 hours
- Resolves: RHEL-106502 - Ignore the memberOfDeferredUpdate setting when
LMDB is used.
- Resolves: RHEL-106559 - When deferred memberof update is enabled after
the server crashed it should not launch memberof fixup task by default
- Resolves: RHEL-106849 - Abort the offline import if the root entry cannot
be added.
- Resolves: RHEL-107003 - Improve output dsctl dbverify when backend does
not exist
- Resolves: RHEL-109113 - [RFE] memberOf plugin - Add scope for specific
groups
- Resolves: RHEL-111219 - Attribute uniqueness is not enforced upon modrdn
operation
- Resolves: RHEL-113965 - RetroCL plugin generates invalid LDIF
- Resolves: RHEL-115179 - Several password related attributes are not
replicating from the Replicas to the Masters
- Resolves: RHEL-115484 - ns-slapd crash in libdb, possible memory
corruption
- Resolves: RHEL-116060 - Fix paged result search locking
- Resolves: RHEL-117124 - Missing access JSON logging for TLS/CLient auth
- Resolves: RHEL-117140 - Changelog trimming - add number of scanned
entries to the log
- Resolves: RHEL-117520 - Typo in errors log after a Memberof fixup task.
- Resolves: RHEL-121208 - [RFE] Make nsslapd-haproxy-trusted-ip accept
whole subnets
- Resolves: RHEL-122625 - ipa-healthcheck is complaining about missing or
incorrectly configured system indexes.
- Resolves: RHEL-122674 - [WebUI] Replication tab crashes after enabling
replication as a consumer
- Resolves: RHEL-123220 - Improve the way to detect asynchronous operations
in the access logs
- Resolves: RHEL-123275 - The new ipahealthcheck test
ipahealthcheck.ds.backends.BackendsCheck raises CRITICAL issue
- Resolves: RHEL-123663 - Online initialization of consumers fails with
error -23
- Resolves: RHEL-123664 - RHDS 12.6 doesn't handle 'ldapsearch' filter with
space char in DN name correctly
- Resolves: RHEL-123762 - 389-ds-base OpenScanHub Leaks Detected
- Resolves: RHEL-124694 - Access logs are not getting deleted as
configured.
- Resolves: RHEL-126535 - memory corruption in alias entry plugin
- Resolves: RHEL-128906 - Scalability issue of replication online
initialization with large database
- Resolves: RHEL-129675 - Can't locate CSN error seen in errors log when
replicating after importing data from ldif files
- Resolves: RHEL-131129 - ns-slapd[2233]: segfault at 0 ip 00007f1f1d7cd7fc
sp 00007f1e775fc070 error 4 in libjemalloc.so.2[7f1f1d738000+ac000] on
389-ds-base-2.6.1-11
- Resolves: RHEL-133795 - Memory leak observed in ns-slapd with 389-ds-
base-2.6.1-12
- Resolves: RHEL-139826 - Rebase 389-ds-base to 3.2.x
* Thu Sep 18 2025 Viktor Ashirov <vashirov@redhat.com> - 3.1.3-5
- Resolves: RHEL-101727 - The numSubordinates value is not matching the
number of direct children.
- Resolves: RHEL-101783 - RHDS12: Web console doesn't show Server Version
- Resolves: RHEL-109018 - Allow Uniqueness plugin to search uniqueness
attributes using custom matching rules
- Resolves: RHEL-111224 - Error showing local password policy on web UI
- Resolves: RHEL-112675 - Statistics about index lookup report a wrong
duration
- Resolves: RHEL-112689 - Crash if repl keep alive entry can not be created
- Resolves: RHEL-112722 - Exception thrown by dsconf instance repl get_ruv
- Resolves: RHEL-113969 - AddressSanitizer: memory leak in
memberof_add_memberof_attr
* Tue Aug 05 2025 Viktor Ashirov <vashirov@redhat.com> - 3.1.3-4
- Resolves: RHEL-73032 - segfault - error 4 in libpthread-2.28.so
- Resolves: RHEL-79079 - Failure to get Server monitoring data when NDN
cache is disabled.
- Resolves: RHEL-87352 - ns-slapd crashed when we add nsslapd-referral
- Resolves: RHEL-92054 - Memory leak in
roles_cache_create_object_from_entry [rhel-10]
- Resolves: RHEL-107001 - ipa-restore fails to restore SELinux contexts,
causes ns-slapd AVC denials on /dev/shm after restore. [rhel-10]
- Resolves: RHEL-107028 - CWE-284 dirsrv log rotation creates files with
world readable permission
- Resolves: RHEL-107035 - CWE-532 Created user password hash available to
see in audit log
- Resolves: RHEL-107037 - CWE-778 Log doesn't show what user gets password
changed by administrator
* Fri Aug 01 2025 Viktor Ashirov <vashirov@redhat.com> - 3.1.3-3
- Resolves: RHEL-80252 - [RFE] Structured (JSON) logging option for RHDS
access and error logs
- Resolves: RHEL-95441 - ns-slapd[xxxx]: segfault at 10d7d0d0 ip
00007ff734050cdb sp 00007ff6de9f1430 error 6 in
libslapd.so.0.1.0[7ff733ec0000+1b3000]
* Thu Jul 10 2025 Viktor Ashirov <vashirov@redhat.com> - 3.1.3-2
- Resolves: RHEL-5117 - ns-slapd crash in
dbmdb_import_prepare_worker_entry()
- Resolves: RHEL-31959 - [RFE] add plugin origin or source in security's
log msg info
- Resolves: RHEL-35241 - ns-slapd crashes in referral mode
- Resolves: RHEL-61327 - Incomplete messages about replication in the
errors log.
- Resolves: RHEL-61353 - dbscan on replication changelog does not display
MOD_TYPE
- Resolves: RHEL-62874 - dsidm: issue when renaming users
- Resolves: RHEL-65660 - DSIDM: Re-enabling user accounts that reached
inactivity limit fails with error
- Resolves: RHEL-67003 - dsconf backend replication monitor fails if
replica id starts with 0
- Resolves: RHEL-67006 - dsconf utility should let you configure the
"uniqueness-exclude-subtrees" parameter of the Attribute Uniqueness plug-
in
- Resolves: RHEL-67019 - Crash in __strlen_sse2 when using the nsRole
filter rewriter.
- Resolves: RHEL-67022 - Password modify extended operation should skip
password policy checks when executed by root DN
- Resolves: RHEL-70117 - Unify how group description can be added to a new
group in WebUI and CLU
- Resolves: RHEL-74085 - Increased memory consumption caused by NDN cache
- Resolves: RHEL-74270 - [RFE] Implement "list-dn" option for dsidm tool in
Directory Server
- Resolves: RHEL-76832 - Wrong backend database name syntax causes "Red Hat
Directory Server" => "Databases" menu blank in Cockpit
- Resolves: RHEL-76837 - dsidm Error: float() argument must be a string or
a number, not 'NoneType'
- Resolves: RHEL-76840 - Monitoring tab should use dsconf monitor
- Resolves: RHEL-77490 - Complete remove the parameter "nsslapd-subtree-
rename-switch" from DS-12
- Resolves: RHEL-79080 - Json option does not work with "dsidm account get-
by-dn" command
- Resolves: RHEL-80252 - [RFE] Structured (JSON) logging option for RHDS
access and error logs
- Resolves: RHEL-80253 - RHDS hangs when having online backup running
together with automember_rebuild task executing
- Resolves: RHEL-80497 - Can't rename users member of automember rule
[rhel-10]
- Resolves: RHEL-81277 - logconv.py fails when specific timestamps are
provided
- Resolves: RHEL-83850 - mdb database statistics don't work
- Resolves: RHEL-86279 - Cannot create a nested role using "dsidm role
create-nested"
- Resolves: RHEL-86280 - Cannot create a filtered role using "dsidm role
create-filtered"
- Resolves: RHEL-86313 - RootDN Access Control Plugin with wildcards for IP
addresses fails with an error "Invalid IP address"
- Resolves: RHEL-86314 - dsidm failing with error "argument must be a
string or a number"
- Resolves: RHEL-86315 - Dsidm get_dn option fails for organizational unit,
service and posixgroup
- Resolves: RHEL-86316 - Dsidm uniquegroup members option does not work
- Resolves: RHEL-86321 - dsidm role rename-by-dn does not rename a role
- Resolves: RHEL-86322 - dsidm role subtree-status doesn't work
- Resolves: RHEL-86323 - dsidm role get-by-dn doesn't work properly with -j
option
- Resolves: RHEL-86324 - Deleting a role with dsidm results in proper
deletion message, but role is still present
- Resolves: RHEL-86785 - dscontainer: support loading custom schema
- Resolves: RHEL-86878 - segfault at 7ff2370010c8 ip 00007ff2339ba239 sp
00007fed321fe100 error 6 in liblmdb.so.0.0.0
- Resolves: RHEL-89748 - Nested group does not receive memberOf attribute
- Resolves: RHEL-89774 - Improve the "result" field of ipa-healthcheck if
replicas are busy [rhel-10]
- Resolves: RHEL-89776 - RHDS12.2 NSMMReplicationPlugin - release_replica
Unable to parse the response
- Resolves: RHEL-95441 - ns-slapd[xxxx]: segfault at 10d7d0d0 ip
00007ff734050cdb sp 00007ff6de9f1430 error 6 in
libslapd.so.0.1.0[7ff733ec0000+1b3000]
- Resolves: RHEL-95761 - Improve error message when bulk import connection
is closed
- Resolves: RHEL-97565 - On RHDS 12.6 The user password policy for a user
was created, but the pwdpolicysubentry attribute for this user
incorrectly points to the People OU password policy instead of the
specific user policy.
- Resolves: RHEL-101926 - ipa-backup failed with error : 'No such file or
directory: '/usr/sbin/dsctl'
* Mon Jun 30 2025 Viktor Ashirov <vashirov@redhat.com> - 3.1.3-1
- Resolves: RHEL-80162 - Rebase 389-ds-base to 3.1.x
* Wed Feb 12 2025 Viktor Ashirov <vashirov@redhat.com> - 3.0.6-2
- Bump version to 3.0.6-3
- Resolves: RHEL-5141 - [RFE] For each request, a ldap client can assign an
identifier to be added in the logs
- Resolves: RHEL-77948 - ns-slapd crashes with data directory ≥ 2 days old
[rhel-10]
- Resolves: RHEL-78342 - During import of entries without nsUniqueId, a
supplier generates duplicate nsUniqueId (LMDB only)
* Wed Jan 29 2025 Viktor Ashirov <vashirov@redhat.com> - 3.0.6-1
- Update to 3.0.6
- Resolves: RHEL-1681 - [RFE] Log buffering for all log types
- Resolves: RHEL-5141 - [RFE] For each request, a ldap client can assign an
identifier to be added in the logs
- Resolves: RHEL-38917 - dscreate interactive install shows a traceback
when mdb is selected
- Resolves: RHEL-42485 - [RFE] pbkdf2 hardcoded parameters should be turned
into configuration options
- Resolves: RHEL-59513 - [RFE] Port logconv.pl to python
- Resolves: RHEL-61253 - Make online import more robust
- Resolves: RHEL-69819 - "Duplicated DN detected" errors when creating
indexes or importing entries. [rhel-10.0]
- Resolves: RHEL-70122 - Crash in attrlist_find() when the Account Policy
plugin is enabled.
- Resolves: RHEL-74149 - backup/restore broken
- Resolves: RHEL-74154 - If an entry RDN is identical to the suffix, then
Entryrdn gets broken during a reindex
- Resolves: RHEL-74159 - Crash during bind when acct policy plugin does not
have "alwaysrecordlogin" set
- Resolves: RHEL-74164 - On replica consumer, account policy plugin fails
to manage the last login history
- Resolves: RHEL-76020 - IPA LDAP error code T3 when no exceeded time limit
from a paged search result [rhel-10]
- Resolves: RHEL-76838 - Unlocked and locked users having same error output
- Resolves: RHEL-76841 - Healthcheck tool should warn admin about creating
a substring index on membership attribute
* Mon Dec 16 2024 Viktor Ashirov <vashirov@redhat.com> - 3.0.5-2
- Fix License tag
- Resolves: RHEL-67196 - Rebase 389-ds-base to 3.0.5
* Mon Dec 16 2024 Viktor Ashirov <vashirov@redhat.com> - 3.0.5-1
- Update to 3.0.5
- Resolves: RHEL-67196 - Rebase 389-ds-base to 3.0.5
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 3.0.4-4
- Bump release for October 2024 mass rebuild:
* Mon Sep 16 2024 Viktor Ashirov <vashirov@redhat.com> - 3.0.4-2
- Resolves: RHEL-58070 - lmdb reindex is broken if index type is specified
/etc/dirsrv /etc/dirsrv/config /etc/dirsrv/config/certmap.conf /etc/dirsrv/config/slapd-collations.conf /etc/dirsrv/schema /etc/dirsrv/schema/99user.ldif /etc/systemd/system/dirsrv.target.wants /usr/bin/dbscan /usr/bin/ds-logpipe.py /usr/bin/ds-replcheck /usr/bin/ldclt /usr/bin/logconv.pl /usr/bin/logconv.py /usr/bin/pwdhash /usr/lib/.build-id /usr/lib/.build-id/01 /usr/lib/.build-id/01/822662b759e96af8d86e95a3be2677021db57a /usr/lib/.build-id/0b /usr/lib/.build-id/0b/8389d285786ee3a718e4df0462f25cdb68e3c7 /usr/lib/.build-id/11 /usr/lib/.build-id/11/bf7559a9c3b4e5854aa2af844bed272d17b4fa /usr/lib/.build-id/12 /usr/lib/.build-id/12/be87a00637f308c1e6e0ddeacf9e39a5345c45 /usr/lib/.build-id/28 /usr/lib/.build-id/28/b51a9ce7d65735f86493a73923d23e67db8d7a /usr/lib/.build-id/2f /usr/lib/.build-id/2f/824c633f85bbe7294651e588eef24c62388fa4 /usr/lib/.build-id/38 /usr/lib/.build-id/38/36fb891d582a927000c3f0139adb13a80330c5 /usr/lib/.build-id/3b /usr/lib/.build-id/3b/4ac2597530981292ccc137dbafbfb63a1cf4e3 /usr/lib/.build-id/3c /usr/lib/.build-id/3c/3125cf4374d6e8dac0f8d8b7b7b766aefc8b3a /usr/lib/.build-id/47 /usr/lib/.build-id/47/0f26263f09fc82653c6f1da7f318fe8f7b541c /usr/lib/.build-id/52 /usr/lib/.build-id/52/3aa42376e1ad9d937e6fc1e5651fa66502615e /usr/lib/.build-id/53 /usr/lib/.build-id/53/4e5454bd0c6ba155146db1134b488b0f5a6adb /usr/lib/.build-id/58 /usr/lib/.build-id/58/622707352a8e929f6652e7f4600bd02ffe6d93 /usr/lib/.build-id/5c /usr/lib/.build-id/5c/ef04644f32c94239c7cb093d4994258a092ee9 /usr/lib/.build-id/5f /usr/lib/.build-id/5f/5472553ce165133d855f7c7f93026e27316e70 /usr/lib/.build-id/6b /usr/lib/.build-id/6b/b9d3cf1740547ff0e59b2e0de4b8fe9683a347 /usr/lib/.build-id/6c /usr/lib/.build-id/6c/42a8d4086a0c82e5b76e48b6746233fb018afa /usr/lib/.build-id/7a /usr/lib/.build-id/7a/44b1718297233ac7c77079f965c8a001351c31 /usr/lib/.build-id/82 /usr/lib/.build-id/82/f460961829355996d35778d936e3256a7d92e0 /usr/lib/.build-id/91 /usr/lib/.build-id/91/7f716c39567a95d3f76c42c4944a37ae762961 /usr/lib/.build-id/93 /usr/lib/.build-id/93/1602550fa8cc79c2f9931fb6dbb9e7ee1fc2ae /usr/lib/.build-id/95 /usr/lib/.build-id/95/7404763313c125ff41174114b3fe12d3152f2f /usr/lib/.build-id/97 /usr/lib/.build-id/97/40be0cbb475f0d74c7daa78b23ed3ae0d10352 /usr/lib/.build-id/99 /usr/lib/.build-id/99/a453493478817edc3964afb8ca77cfa6a65184 /usr/lib/.build-id/9a /usr/lib/.build-id/9a/b9db8a43ea78c76b56e7273ecf3d66f5052f8f /usr/lib/.build-id/a1 /usr/lib/.build-id/a1/a2078e5716c744032706248ebf448ddbe351eb /usr/lib/.build-id/a3 /usr/lib/.build-id/a3/ae27b5f494af1faaa873ee08439c0445ecab5c /usr/lib/.build-id/a5 /usr/lib/.build-id/a5/d153a851eaf71d83432e5d3100ff1c498136de /usr/lib/.build-id/ae /usr/lib/.build-id/ae/afd9fcad0e92a08d31eccb9d573bcb16874fc2 /usr/lib/.build-id/b1 /usr/lib/.build-id/b1/036cf8372e882ef9c43e87809843a7306e007b /usr/lib/.build-id/b3 /usr/lib/.build-id/b3/4488469fe99900aff4308270f1ccd1ef18bb68 /usr/lib/.build-id/c4 /usr/lib/.build-id/c4/c751091c5ad6697406d7550e4c62ae765306e1 /usr/lib/.build-id/c8 /usr/lib/.build-id/c8/a963cd31dd097d49f6f278c0686d9caa518f30 /usr/lib/.build-id/cb /usr/lib/.build-id/cb/b3356aa6b70b2be25c33df8387d22a14c4bb6f /usr/lib/.build-id/cf /usr/lib/.build-id/cf/f82fedb1ce37425d39ceb16293ccf630a31ed6 /usr/lib/.build-id/d1 /usr/lib/.build-id/d1/e9388398790f34974c622dde4acae99dbaa13c /usr/lib/.build-id/d4 /usr/lib/.build-id/d4/b7887772a78f8fc34fb3ee8e898fbd217cd51c /usr/lib/.build-id/d7 /usr/lib/.build-id/d7/c744ca9117c6e8497400e631b761c0c2dba007 /usr/lib/.build-id/d9 /usr/lib/.build-id/d9/8c39cf2469caf4bbe53db381ce0c8ad3839bee /usr/lib/.build-id/dc /usr/lib/.build-id/dc/841361fa4e6af5b39324fbfea903ceed09f597 /usr/lib/.build-id/e6 /usr/lib/.build-id/e6/a1053c22e455bad165f968d33e15eb86a98004 /usr/lib/.build-id/ea /usr/lib/.build-id/ea/208be251ec11193d5757365e73af72df1684fe /usr/lib/.build-id/ea/44f30135d1886d508917b239f3d7e9868cfd47 /usr/lib/.build-id/fe /usr/lib/.build-id/fe/9d5cfd359d05ce73f93fbcd22a11ddf23903ec /usr/lib/sysctl.d/70-dirsrv.conf /usr/lib/systemd/system /usr/lib/systemd/system/dirsrv.target /usr/lib/systemd/system/dirsrv@.service /usr/lib/systemd/system/dirsrv@.service.d /usr/lib/systemd/system/dirsrv@.service.d/custom.conf /usr/lib/sysusers.d/389-ds-base.conf /usr/lib64/dirsrv/bin /usr/lib64/dirsrv/bin/jeprof /usr/lib64/dirsrv/lib /usr/lib64/dirsrv/lib/libjemalloc.so.2 /usr/lib64/dirsrv/plugins /usr/lib64/dirsrv/plugins/libacctpolicy-plugin.so /usr/lib64/dirsrv/plugins/libacctusability-plugin.so /usr/lib64/dirsrv/plugins/libacl-plugin.so /usr/lib64/dirsrv/plugins/libaddn-plugin.so /usr/lib64/dirsrv/plugins/libalias-entries-plugin.so /usr/lib64/dirsrv/plugins/libattr-unique-plugin.so /usr/lib64/dirsrv/plugins/libautomember-plugin.so /usr/lib64/dirsrv/plugins/libback-ldbm.so /usr/lib64/dirsrv/plugins/libbitwise-plugin.so /usr/lib64/dirsrv/plugins/libchainingdb-plugin.so /usr/lib64/dirsrv/plugins/libcollation-plugin.so /usr/lib64/dirsrv/plugins/libcontentsync-plugin.so /usr/lib64/dirsrv/plugins/libcos-plugin.so /usr/lib64/dirsrv/plugins/libderef-plugin.so /usr/lib64/dirsrv/plugins/libdistrib-plugin.so /usr/lib64/dirsrv/plugins/libdna-plugin.so /usr/lib64/dirsrv/plugins/libentryuuid-plugin.so /usr/lib64/dirsrv/plugins/libentryuuid-syntax-plugin.so /usr/lib64/dirsrv/plugins/liblinkedattrs-plugin.so /usr/lib64/dirsrv/plugins/libmanagedentries-plugin.so /usr/lib64/dirsrv/plugins/libmemberof-plugin.so /usr/lib64/dirsrv/plugins/libpam-passthru-plugin.so /usr/lib64/dirsrv/plugins/libpassthru-plugin.so /usr/lib64/dirsrv/plugins/libpbe-plugin.so /usr/lib64/dirsrv/plugins/libposix-winsync-plugin.so /usr/lib64/dirsrv/plugins/libpwdchan-plugin.so /usr/lib64/dirsrv/plugins/libpwdstorage-plugin.so /usr/lib64/dirsrv/plugins/libreferint-plugin.so /usr/lib64/dirsrv/plugins/libreplication-plugin.so /usr/lib64/dirsrv/plugins/libretrocl-plugin.so /usr/lib64/dirsrv/plugins/libroles-plugin.so /usr/lib64/dirsrv/plugins/librootdn-access-plugin.so /usr/lib64/dirsrv/plugins/libschemareload-plugin.so /usr/lib64/dirsrv/plugins/libstatechange-plugin.so /usr/lib64/dirsrv/plugins/libsyntax-plugin.so /usr/lib64/dirsrv/plugins/libusn-plugin.so /usr/lib64/dirsrv/plugins/libviews-plugin.so /usr/lib64/dirsrv/plugins/libwhoami-plugin.so /usr/lib64/dirsrv/python /usr/lib64/dirsrv/python/failedbinds.py /usr/lib64/dirsrv/python/logregex.py /usr/libexec/dirsrv/ds_selinux_restorecon.sh /usr/libexec/dirsrv/ds_systemd_ask_password_acl /usr/sbin/ns-slapd /usr/sbin/openldap_to_ds /usr/share/bash-completion/completions/ds-replcheck /usr/share/dirsrv /usr/share/dirsrv/data /usr/share/dirsrv/data/10rfc2307bis.ldif /usr/share/dirsrv/data/10rfc2307compat.ldif /usr/share/dirsrv/data/60changelog.ldif /usr/share/dirsrv/data/60inetmail.ldif /usr/share/dirsrv/data/60kerberos.ldif /usr/share/dirsrv/data/60krb5kdc.ldif /usr/share/dirsrv/data/60nis.ldif /usr/share/dirsrv/data/60qmail.ldif /usr/share/dirsrv/data/60radius.ldif /usr/share/dirsrv/data/60rfc4876.ldif /usr/share/dirsrv/data/60samba.ldif /usr/share/dirsrv/data/60sendmail.ldif /usr/share/dirsrv/data/Ace.ldif /usr/share/dirsrv/data/European.ldif /usr/share/dirsrv/data/Eurosuffix.ldif /usr/share/dirsrv/data/Example-roles.ldif /usr/share/dirsrv/data/Example-views.ldif /usr/share/dirsrv/data/Example.ldif /usr/share/dirsrv/data/dbgen-FamilyNames /usr/share/dirsrv/data/dbgen-GivenNames /usr/share/dirsrv/data/dbgen-OrgUnits /usr/share/dirsrv/data/dsee.schema /usr/share/dirsrv/data/template-baseacis.ldif /usr/share/dirsrv/data/template-country.ldif /usr/share/dirsrv/data/template-domain.ldif /usr/share/dirsrv/data/template-dse-minimal.ldif /usr/share/dirsrv/data/template-dse.ldif /usr/share/dirsrv/data/template-ldapi-autobind.ldif /usr/share/dirsrv/data/template-ldapi-default.ldif /usr/share/dirsrv/data/template-ldapi.ldif /usr/share/dirsrv/data/template-locality.ldif /usr/share/dirsrv/data/template-org.ldif /usr/share/dirsrv/data/template-orgunit.ldif /usr/share/dirsrv/data/template-sasl.ldif /usr/share/dirsrv/data/template-state.ldif /usr/share/dirsrv/data/template-suffix-db.ldif /usr/share/dirsrv/data/template.ldif /usr/share/dirsrv/inf /usr/share/dirsrv/inf/defaults.inf /usr/share/dirsrv/inf/slapd.inf /usr/share/dirsrv/mibs /usr/share/dirsrv/mibs/redhat-directory.mib /usr/share/dirsrv/profiling /usr/share/dirsrv/profiling/bpftrace /usr/share/dirsrv/profiling/bpftrace/probe_do_search_detail.bt /usr/share/dirsrv/profiling/bpftrace/probe_log_access_detail.bt /usr/share/dirsrv/profiling/bpftrace/probe_op_shared_search.bt /usr/share/dirsrv/profiling/bpftrace/probe_work_queue.bt /usr/share/dirsrv/profiling/stap /usr/share/dirsrv/profiling/stap/probe_do_search_detail.stp /usr/share/dirsrv/profiling/stap/probe_log_access_detail.stp /usr/share/dirsrv/profiling/stap/probe_op_shared_search.stp /usr/share/dirsrv/profiling/stap/probe_work_queue.stp /usr/share/dirsrv/schema /usr/share/dirsrv/schema/00core.ldif /usr/share/dirsrv/schema/01core389.ldif /usr/share/dirsrv/schema/02common.ldif /usr/share/dirsrv/schema/03entryuuid.ldif /usr/share/dirsrv/schema/05rfc2927.ldif /usr/share/dirsrv/schema/05rfc4523.ldif /usr/share/dirsrv/schema/05rfc4524.ldif /usr/share/dirsrv/schema/06inetorgperson.ldif /usr/share/dirsrv/schema/10automember-plugin.ldif /usr/share/dirsrv/schema/10dna-plugin.ldif /usr/share/dirsrv/schema/10mep-plugin.ldif /usr/share/dirsrv/schema/10rfc2307compat.ldif /usr/share/dirsrv/schema/20subscriber.ldif /usr/share/dirsrv/schema/25java-object.ldif /usr/share/dirsrv/schema/28pilot.ldif /usr/share/dirsrv/schema/30ns-common.ldif /usr/share/dirsrv/schema/50ns-admin.ldif /usr/share/dirsrv/schema/50ns-certificate.ldif /usr/share/dirsrv/schema/50ns-directory.ldif /usr/share/dirsrv/schema/50ns-mail.ldif /usr/share/dirsrv/schema/50ns-value.ldif /usr/share/dirsrv/schema/50ns-web.ldif /usr/share/dirsrv/schema/60acctpolicy.ldif /usr/share/dirsrv/schema/60autofs.ldif /usr/share/dirsrv/schema/60eduperson.ldif /usr/share/dirsrv/schema/60mozilla.ldif /usr/share/dirsrv/schema/60nss-ldap.ldif /usr/share/dirsrv/schema/60pam-plugin.ldif /usr/share/dirsrv/schema/60posix-winsync-plugin.ldif /usr/share/dirsrv/schema/60pureftpd.ldif /usr/share/dirsrv/schema/60rfc2739.ldif /usr/share/dirsrv/schema/60rfc3712.ldif /usr/share/dirsrv/schema/60sabayon.ldif /usr/share/dirsrv/schema/60samba3.ldif /usr/share/dirsrv/schema/60sudo.ldif /usr/share/dirsrv/schema/60trust.ldif /usr/share/doc/389-ds-base /usr/share/doc/389-ds-base/LICENSE /usr/share/doc/389-ds-base/LICENSE.GPLv3+ /usr/share/doc/389-ds-base/LICENSE.openssl /usr/share/doc/389-ds-base/README.jemalloc /usr/share/gdb/auto-load/usr /usr/share/gdb/auto-load/usr/sbin /usr/share/gdb/auto-load/usr/sbin/ns-slapd-gdb.py /usr/share/licenses/389-ds-base /usr/share/licenses/389-ds-base/COPYING.jemalloc /usr/share/man/man1/dbscan.1.gz /usr/share/man/man1/ds-logpipe.py.1.gz /usr/share/man/man1/ds-replcheck.1.gz /usr/share/man/man1/ldclt.1.gz /usr/share/man/man1/logconv.pl.1.gz /usr/share/man/man1/logconv.py.1.gz /usr/share/man/man1/pwdhash.1.gz /usr/share/man/man5/99user.ldif.5.gz /usr/share/man/man5/certmap.conf.5.gz /usr/share/man/man5/dirsrv.5.gz /usr/share/man/man5/dirsrv.systemd.5.gz /usr/share/man/man5/slapd-collations.conf.5.gz /usr/share/man/man8/ns-slapd.8.gz /usr/share/man/man8/openldap_to_ds.8.gz /var/lib/dirsrv /var/lock/dirsrv /var/log/dirsrv
Generated by rpm2html 1.8.1
Fabrice Bellet, Wed Sep 23 09:45:26 2026